<!DOCTYPE html>
<html lang="en-US"
	prefix="og: https://ogp.me/ns#"  class="">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://cabinradio.ca/xmlrpc.php">

<title>Hay River keeps holiday spirit alive despite Covid-19</title>

		<!-- All in One SEO Pro 4.0.4 -->
		<meta name="description" content="A Santa Claus parade, a new event at the town&#039;s territorial park, Secret Santa, and the annual toy drive: here&#039;s how to participate in Hay River&#039;s festivities."/>
		<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
		<meta name="keywords" content="hay river,christmas,holiday,activities,parade,santa claus,2020,south slave" />
		<link rel="canonical" href="https://cabinradio.ca/50028/news/south-slave/hay-river-keeps-holiday-spirit-alive-despite-covid-19/" />
		<meta property="og:site_name" content="Cabin Radio" />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="Hay River keeps holiday spirit alive despite Covid-19" />
		<meta property="og:description" content="A Santa Claus parade, a new event at the town&#039;s territorial park, Secret Santa, and the annual toy drive: here&#039;s how to participate in Hay River&#039;s festivities." />
		<meta property="og:url" content="https://cabinradio.ca/50028/news/south-slave/hay-river-keeps-holiday-spirit-alive-despite-covid-19/" />
		<meta property="fb:app_id" content="485386515233758" />
		<meta property="fb:admins" content="36801254" />
		<meta property="og:image" content="https://cabinradio.ca/wp-content/uploads/2018/12/DSC02361-960x540.jpg" />
		<meta property="og:image:secure_url" content="https://cabinradio.ca/wp-content/uploads/2018/12/DSC02361-960x540.jpg" />
		<meta property="og:image:width" content="740" />
		<meta property="og:image:height" content="416" />
		<meta property="article:tag" content="hay river" />
		<meta property="article:tag" content="christmas" />
		<meta property="article:tag" content="holiday" />
		<meta property="article:tag" content="activities" />
		<meta property="article:tag" content="parade" />
		<meta property="article:tag" content="santa claus" />
		<meta property="article:tag" content="2020" />
		<meta property="article:tag" content="south slave" />
		<meta property="article:published_time" content="2020-11-27T15:21:43Z" />
		<meta property="article:modified_time" content="2020-11-27T15:21:43Z" />
		<meta property="article:publisher" content="https://www.facebook.com/cabinradio" />
		<meta property="twitter:card" content="summary_large_image" />
		<meta property="twitter:site" content="@cabinradio" />
		<meta property="twitter:domain" content="cabinradio.ca" />
		<meta property="twitter:title" content="Hay River keeps holiday spirit alive despite Covid-19" />
		<meta property="twitter:description" content="A Santa Claus parade, a new event at the town&#039;s territorial park, Secret Santa, and the annual toy drive: here&#039;s how to participate in Hay River&#039;s festivities." />
		<meta property="twitter:creator" content="@Sarah_Sibley_" />
		<meta property="twitter:image" content="https://cabinradio.ca/wp-content/uploads/2018/12/DSC02361-960x540.jpg" />
		<meta property="twitter:label1" content="Written by" />
		<meta property="twitter:data1" content="Sarah Sibley" />
		<meta property="twitter:label2" content="Est. reading time" />
		<meta property="twitter:data2" content="3 minutes" />
		<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/cabinradio.ca\/#website","url":"https:\/\/cabinradio.ca\/","name":"Cabin Radio","description":"Life's Better at the Cabin","publisher":{"@id":"https:\/\/cabinradio.ca\/#organization"},"potentialAction":{"@type":"SearchAction","target":"https:\/\/cabinradio.ca\/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"Organization","@id":"https:\/\/cabinradio.ca\/#organization","name":"Cabin Radio","url":"https:\/\/cabinradio.ca\/","logo":{"@type":"ImageObject","@id":"https:\/\/cabinradio.ca\/#organizationLogo","url":"https:\/\/cabinradio.ca\/wp-content\/uploads\/2018\/01\/CURRENTLY-USED-Icon_Tundra.png","width":596,"height":596},"image":{"@id":"https:\/\/cabinradio.ca\/#organizationLogo"},"sameAs":["https:\/\/www.facebook.com\/cabinradio","https:\/\/twitter.com\/cabinradio","http:\/\/instagram.com\/cabinradio"]},{"@type":"BreadcrumbList","@id":"https:\/\/cabinradio.ca\/50028\/news\/south-slave\/hay-river-keeps-holiday-spirit-alive-despite-covid-19\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/cabinradio.ca\/#listItem","position":1,"item":{"@type":"CollectionPage","@id":"https:\/\/cabinradio.ca\/#item","name":"Cabin Radio","description":"News and radio for Yellowknife and the Northwest Territories, including the Dehcho, Sahtu, Beaufort Delta, South Slave, North Slave, and T\u0142\u0131\u0328ch\u01eb.","url":"https:\/\/cabinradio.ca\/"},"nextItem":"https:\/\/cabinradio.ca\/50028\/news\/south-slave\/hay-river-keeps-holiday-spirit-alive-despite-covid-19\/#listItem"},{"@type":"ListItem","@id":"https:\/\/cabinradio.ca\/50028\/news\/south-slave\/hay-river-keeps-holiday-spirit-alive-despite-covid-19\/#listItem","position":2,"item":{"@id":"https:\/\/cabinradio.ca\/50028\/news\/south-slave\/hay-river-keeps-holiday-spirit-alive-despite-covid-19\/#item","name":"Hay River keeps holiday spirit alive despite Covid-19","description":"A Santa Claus parade, a new event at the town's territorial park, Secret Santa, and the annual toy drive: here's how to participate in Hay River's festivities.","url":"https:\/\/cabinradio.ca\/50028\/news\/south-slave\/hay-river-keeps-holiday-spirit-alive-despite-covid-19\/"},"previousItem":"https:\/\/cabinradio.ca\/#listItem"}]},{"@type":"Person","@id":"https:\/\/cabinradio.ca\/author\/cabinsibley\/#author","url":"https:\/\/cabinradio.ca\/author\/cabinsibley\/","name":"Sarah Sibley","sameAs":["https:\/\/www.facebook.com\/cabinradio","https:\/\/twitter.com\/Sarah_Sibley_","http:\/\/instagram.com\/cabinradio"]}]}
		</script>
		<script type="text/javascript" >
			window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
			ga('create', "UA-111371112-1", { 'cookieDomain': 'cabinradio.ca' } );
			ga('require', 'outboundLinkTracker');
			ga('require', 'mediaQueryTracker');
			ga('require', 'maxScrollTracker');
			ga('require', 'cleanUrlTracker');
			ga('send', 'pageview');
		</script>
		<script async src="https://www.google-analytics.com/analytics.js"></script>
		<script async src="https://cabinradio.ca/wp-content/plugins/all-in-one-seo-pack-pro/app/Common/Assets/js/autotrack.js?ver=4.0.4"></script>
		<!-- All in One SEO Pro -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Cabin Radio &raquo; Feed" href="https://cabinradio.ca/feed/" />
<link rel="alternate" type="application/rss+xml" title="Cabin Radio &raquo; Comments Feed" href="https://cabinradio.ca/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/cabinradio.ca\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-9c044cac1123a387842b7022f64a7bbb' href='https://cabinradio.ca/_static/??-eJyNkt1uwyAMhV9oLl3VdbuZ9iwOdlpW/gSmWd5+pCHSVjXdbkIM3zkG20MEHbywFxVtORqf1SdLRH1WLlCxnFVii8IEMWS5iTY656chgvHaFqpsjRWZLKqzQZ/Bmi5hGlWW0fLGGb8IbnNaHEMROCZDDV4Bdbg6tyxLBHc1rsAiG6IOLp/UhT2FpLBIcChitBL+EnBMBmEwdGSZveantJ2JWb1Q5xMF6BmlpFqXiyEOCnNmmT0aEEtnjW7m66/zglqgD8nBq/pV1vtKObGrgJjp+zcC+mQs/cer5lZ9PQAcOAf3sHsRJQUPXRGpC3pqpczQjRUm7jBRo2vBXZxGqLaQeyxWHjc8O0wCiXXdnIeumf+scU5xgD5dpbTmtMz1JGj/E/rh3p8P28N++7Z72X0DoNEr4A==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='times-fonts-css'  href='https://fonts.googleapis.com/css?family=PT+Serif%3A400%2C700%2C400italic%2C700italic%7CDomine%3A400%2C700%7CWork+Sans%3A300%2C400%2C500%2C600%2C700%2C900&#038;subset=latin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Cvietnamese&#038;ver=5.5.3' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<script src='https://cabinradio.ca/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script id='jetpack_related-posts-js-extra'>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script type='text/javascript'  src='https://cabinradio.ca/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?m=1592324036'></script>
<link rel="https://api.w.org/" href="https://cabinradio.ca/wp-json/" /><link rel="alternate" type="application/json" href="https://cabinradio.ca/wp-json/wp/v2/posts/50028" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cabinradio.ca/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cabinradio.ca/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p9akY2-d0U' />
<link rel="alternate" type="application/json+oembed" href="https://cabinradio.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcabinradio.ca%2F50028%2Fnews%2Fsouth-slave%2Fhay-river-keeps-holiday-spirit-alive-despite-covid-19%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://cabinradio.ca/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcabinradio.ca%2F50028%2Fnews%2Fsouth-slave%2Fhay-river-keeps-holiday-spirit-alive-despite-covid-19%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.8 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.gcabinr { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.gcabinr img { height:auto; }
	.gcabinr-col { position:relative; float:left; }
	.gcabinr-col:first-child { margin-left: 0; }
	.gcabinr-col:last-child { margin-right: 0; }
	.gcabinr-18 { min-width:10px; max-width:640px; margin: 0 auto; }
	.bcabinr-18 { margin:0px 10px 30px 10px; }
	.gcabinr-7 { min-width:0px; max-width:1200px; margin: 0 auto; }
	.bcabinr-7 { margin:0px 0px 30px 0px; }
	.gcabinr-10 {  margin: 0 auto; }
	.gcabinr-12 {  margin: 0 auto; }
	.gcabinr-15 {  margin: 0 auto; }
	.gcabinr-7 { min-width:0px; max-width:1200px; margin: 0 auto; }
	.bcabinr-7 { margin:0px 0px 30px 0px; }
	.gcabinr-17 {  margin: 0 auto; }
	.gcabinr-19 {  margin: 0 auto; }
	.gcabinr-10 {  margin: 0 auto; }
	.gcabinr-19 {  margin: 0 auto; }
	.gcabinr-15 {  margin: 0 auto; }
	.gcabinr-16 {  margin: 0 auto; }
	.gcabinr-21 {  margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.gcabinr-col, .gcabinr-dyn, .gcabinr-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="https://cabinradio.ca/wp-content/uploads/2018/01/cropped-CURRENTLY-USED-Icon_Tundra-32x32.png" sizes="32x32" />
<link rel="icon" href="https://cabinradio.ca/wp-content/uploads/2018/01/cropped-CURRENTLY-USED-Icon_Tundra-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://cabinradio.ca/wp-content/uploads/2018/01/cropped-CURRENTLY-USED-Icon_Tundra-180x180.png" />
<meta name="msapplication-TileImage" content="https://cabinradio.ca/wp-content/uploads/2018/01/cropped-CURRENTLY-USED-Icon_Tundra-270x270.png" />
<style id="timesPrimaryColorCustom" type="text/css" media="screen">#comments .bypostauthor .comment-meta .comment-author b,#comments .reply,#comments #respond~p a,.bass a,#sec-navigation .menu li:hover,#sec-navigation .menu>li.page_item_has_children:hover,#sec-navigation .menu>li.menu-item-has-children:hover,#sec-navigation .menu>li>ul li:hover,#sec-navigation.layout-boxed.background-dark .menu li:hover,.post.expt .meta .spsd:after,.post.mass .introduction .meta .spsd:after,.post.mass .content h1 a,.post.mass .content h2 a,.post.mass .content h3 a,.post.mass .content h4 a,.post.mass .content h5 a,.post.mass .content h6 a,.post.mass .content .wp-block-button.is-style-outline .wp-block-button__link:not(.has-text-color),.error404 .times_get_archives li:hover,.error404 .widget_recent_entries li:hover a,.introduction .meta .post-author,.introduction .times-breadcrumbs>span:hover,.introduction .times-breadcrumbs>span:hover+.separator,.introduction.archive-header.author .meta.author-bio span:hover,.post-author-bio .more-link,.post.expt .more-link,.site-footer .widget.col ul li a:hover,.site-header .site-branding p,.error404 .most_used_categories .cat-item span:first-child:hover,#times-legal-notice .notice-desc-box a{color:#ed5734;}#mobile-nav ul.social-media-list li.fa-envelope,.tvote-wrap.standard .button i:last-of-type:after,.tvote-wrap.standard .button i:last-of-type:before,#commentform .form-submit input,#wp-calendar tbody #today:before,.error404 .times_get_archives li:hover .count,.post.mass .content p>a.button.blue,.post.mass .content .wp-block-file .wp-block-file__button:hover,.post.mass .content .wp-block-button:not(.is-style-outline) .wp-block-button__link:not(.has-background),.post.mass .content .wp-block-times-button a,.post.mass .inaction .share-btn .tooltip .copy-link,.stickyadelesq a,#times-legal-notice .show-button .notice-button{background:#ed5734;}.post.mass .content .wp-block-button.is-style-outline .wp-block-button__link:not(.has-text-color),.bass input[type=button]:focus,.bass input[type=date]:focus,.bass input[type=datetime-local]:focus,.bass input[type=email]:focus,.bass input[type=file]:focus,.bass input[type=month]:focus,.bass input[type=number]:focus,.bass input[type=password]:focus,.bass input[type=reset]:focus,.bass input[type=search]:focus,.bass input[type=submit]:focus,.bass input[type=tel]:focus,.bass input[type=text]:focus,.bass input[type=time]:focus,.bass input[type=url]:focus,.bass input[type=week]:focus,.bass textarea:focus,#commentform .comment-form-comment textarea:focus,#commentform .comment-form-email input:focus,#times-legal-notice .invert-colors .notice-button{border-color:#ed5734;}.post.mass .inaction .recommend-btn.liked:hover #bigbookmark path,.post.mass .inaction .recommend-btn.liked:hover #bigbookmark polygon,.tvote-wrap.small.liked:hover .button svg .out,.tvote-wrap.small.liked:hover .button svg .in{fill:#ed5734;}#commentform .form-submit input:focus{-webkit-box-shadow:0 2px 10px -1px #ed5734;box-shadow:0 2px 10px -1px #ed5734}.post.expt .meta .spsd:hover:before,.post.mass .introduction .meta .spsd:hover:before{color:#ed5734;background:rgba(237,87,52,.25);}#times-legal-notice .notice-desc-box a{-webkit-box-shadow: inset 0 -1px 0 rgba(237,87,52,.5); box-shadow: inset 0 -1px 0 rgba(237,87,52,.5);}</style>
<style id="timesSecondaryColorCustom" type="text/css" media="screen">.post.mass .introduction .meta .sticky{color:#B95B51;}.post.expt .sticky,.tvote-wrap.standard.liked i:last-of-type:before,.tvote-wrap.standard.liked i:last-of-type:after,.post.mass .introduction .meta .sticky{background:#B95B51;}.post.vert-med.sticky h1:before,.post.mass .content p>span.alert.red{background-color:#B95B51;}</style>
<style id="timesShade1ColorCustom" type="text/css" media="screen">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</style>
<style id="timesShade1dColorCustom" type="text/css" media="screen">#comments .wp-social-login-widget .wp-social-login-provider:hover,#wp-calendar caption,.archive-pagination ul.page-numbers li .dots:before,.bass.content table thead td,.bass.content table thead th,.post.mass .introduction .meta .sticky,.post.mass .content form>p input[type=submit],.section-darker .search-form .search-submit,.site-footer .widget:after,#comments .times-comments-control:before{background:#E3E3E3;}.post.mass .content .wp-block-latest-comments .wp-block-latest-comments__comment article:before,.post.mass .content .wp-block-latest-posts.is-grid li:before,#comments .comment-meta .edit-link:before,.introduction .times-breadcrumbs .separator{color:#E3E3E3;}.post.mass .content .wp-block-pullquote cite a,.post.mass .content .wp-block-audio figcaption:before,.post.mass .content .wp-block-video figcaption:before,.post.mass .content .wp-block-embed figcaption:before,.post.mass .content .wp-block-times-button a.style-minimal,#comments .comment>ul.children,#comments .nav-links,#comments ul.children .comment,#comments ul.children ul.children .comment,#site-navigation.custom-menu .top-level-post-area .top-section-info .more-btn,#wp-calendar,.bass.content table,.bass.content table thead td,.bass.content table thead th,.post.mass .content form>p input[type=button], .post.mass .content form>p input[type=date], .post.mass .content form>p input[type=datetime-local], .post.mass .content form>p input[type=email], .post.mass .content form>p input[type=file], .post.mass .content form>p input[type=month], .post.mass .content form>p input[type=number], .post.mass .content form>p input[type=password], .post.mass .content form>p input[type=reset], .post.mass .content form>p input[type=search], .post.mass .content form>p input[type=submit], .post.mass .content form>p input[type=tel], .post.mass .content form>p input[type=text], .post.mass .content form>p input[type=time], .post.mass .content form>p input[type=url], .post.mass .content form>p input[type=week],.post.mass .content form>p textarea,.post.mass .content form>p select,.post.mass .content blockquote.times-quote .author a,.search-form input:focus,.section-darker .bd2:after,.section-darker .search-form .search-field,.section-darker select,.site-footer .add-widgets,.site-footer .widget-area .widget_times_social_widget div,.site-footer .widget.categories li,.site-footer .widget.pages li,.site-footer .widget.social li,.site-footer .widget.widget_nav_menu li,.singular-comments-sidebar,#comments .comment-awaiting-moderation,#comments .comments-closed,#comments .logged-in-as,#comments .nav-links,#comments .wp-social-login-widget,#comments .oneall_social_login{border-color:#E3E3E3;}#times-legal-notice .invert-colors .notice-close .close-svg path{stroke:#E3E3E3;}</style>
<style id="timesShade2ColorCustom" type="text/css" media="screen">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</style>
<style id="timesShade3ColorCustom" type="text/css" media="screen">#commentform,#comments,#comments .comment-content,#comments .tvote-wrap,#comments #respond~p,#site-navigation .rich-dropdown .child-cats,#sec-navigation .menu li,#site-navigation.custom-menu .std-dropdown>ul>li,.archive-pagination ul.page-numbers li a.page-numbers:hover,.bass p,.bass ul,.bass ol,.introduction .times-breadcrumbs>span.item-current:hover,.introduction.archive-header.author .meta.author-bio .bio,.introduction.archive-header.author .meta.author-bio .bio:hover,.post-author-bio p,.post.expt .excerpt,.post.mass .content,.post.mass .content form.post-password-form>p:first-child,.post.mass .content form>p input[type=button], .post.mass .content form>p input[type=date], .post.mass .content form>p input[type=datetime-local], .post.mass .content form>p input[type=email], .post.mass .content form>p input[type=file], .post.mass .content form>p input[type=month], .post.mass .content form>p input[type=number], .post.mass .content form>p input[type=password], .post.mass .content form>p input[type=reset], .post.mass .content form>p input[type=search], .post.mass .content form>p input[type=submit], .post.mass .content form>p input[type=tel], .post.mass .content form>p input[type=text], .post.mass .content form>p input[type=time], .post.mass .content form>p input[type=url], .post.mass .content form>p input[type=week],.post.mass .content form>p textarea,.post.mass .content form>p select,.post.mass .content ol:not([class]) u,.post.mass .content ul:not([class]) u,.post.mass .content>p:not(.long)>u,.post.mass .content .wp-block-pullquote cite,.post.mass .content .wp-block-quote cite,.post.mass .content .wp-block-file a:not([download]):first-of-type:before,.post.mass .content .wp-block-times-button a.style-minimal:before,.query-fade-wrap .info,.search-form .search-submit,.site-footer .site-branding,.site-footer .widget,.site-footer .widget-area .widget_nav_menu a:not(:hover),.site-footer.mini-layout .social-networks a:not(:hover),.stats .stat .text,.times-mini-stats .stat .count,.widget-area.article-sidebar .tags,body.times-customizer-focus-sidebar .widget-area.article-sidebar:not(:hover) .bass a,body.times-customizer-focus-sidebar .widget-area.article-sidebar:not(:hover) .post-author-bio a,body.error404 .e404-header .go-back,#times-legal-notice .notice-desc-box{color:#070707;}#site-navigation .rich-dropdown .child-cats li.active a,.load-more span,body.times-customizer-focus-sidebar .widget-area.article-sidebar:not(:hover) .times-post-share-buttons a:nth-of-type(odd),.site-footer .widget.categories a span.count,#comments .times-comments-control .sorting div.active,#comments .times-comments-control .comments-pagination div{background:#070707;}</style>
<style id="timesBackgroundPrimaryColor" type="text/css" media="screen">.post.mass .content>p:not(.button-paragraph)>a{-webkit-box-shadow:inset 0 -1px 0 #ffffff,inset 0 -2px 0 #ed5734;box-shadow:inset 0 -1px 0 #ffffff,inset 0 -2px 0 #ed5734}.post.mass .content h1 a,.post.mass .content h2 a,.post.mass .content h3 a,.post.mass .content h4 a {-webkit-box-shadow:inset 0 -3px 0 #ffffff,inset 0 -4px 0 rgba(237,87,52,.3);box-shadow: inset 0 -3px 0 #ffffff,inset 0 -4px 0 rgba(237,87,52,.3);}.post.mass .content h5 a, .post.mass .content h6 a {-webkit-box-shadow:inset 0 -1px 0 #ffffff, inset 0 -2px 0 rgba(237,87,52,.3);box-shadow:inset 0 -1px 0 #ffffff, inset 0 -2px 0 rgba(237,87,52,.3);}@media(min-width:600px){.post.mass .content h1 a,.post.mass .content h2 a,.post.mass .content h3 a{-webkit-box-shadow:inset 0 -4px 0 #ffffff,inset 0 -5px 0 rgba(237,87,52,.3);box-shadow:inset 0 -4px 0 #ffffff,inset 0 -5px 0 rgba(237,87,52,.3);}.post.mass .content h5 a{-webkit-box-shadow:inset 0 -2px 0 #ffffff,inset 0 -3px 0 rgba(237,87,52,.3);box-shadow:inset 0 -2px 0 #ffffff,inset 0 -3px 0 rgba(237,87,52,.3);}}</style><style id="timesCustomizerFonts" type="text/css" media="screen">html,select,#mobile-nav,#mobile-nav h3,#mobile-nav.basic-layout .search-container .custom-search-form .search-field,#mobile-nav.compact-layout .custom-search-form .search-field,#mobile-nav.compact-layout .menu-section .close-menu-btn,#sec-navigation .menu li,#sec-navigation .date,#site-navigation ul:not(.child-cats):not(.child-cats-elems) > li,#site-navigation .rich-dropdown .child-cats,#site-navigation .rich-dropdown .more-in-cat,#site-navigation .compact-menu .compact-menu-btn,#site-navigation.custom-menu .std-dropdown ul li,#site-navigation.custom-menu .top-level-post-area .top-section-info h1,#site-navigation.custom-menu .top-level-post-area .top-section-info .cat-description,#site-navigation.custom-menu .top-level-post-area .top-section-info .cat-post-count,#site-navigation.custom-menu .top-level-post-area .top-section-info .more-btn,#site-navigation.custom-menu .post-cat-area .more-in-cat,.site-header.mini .narrow-controls .menu-btn,.site-header.mini .times-instant-search .search-field,.post.expt .meta,.post.expt .meta .spsd,.post.expt .excerpt b,.post.expt .more-link,.category-labels,.tvote-wrap.standard .context,.tvote-wrap.small .context,.post.vert-med .meta,.post.vert-mini p.meta,.category-section .section-header h2,.post.mass .introduction .meta .spsd,.post.mass .featured-image figcaption,.post.mass .content blockquote.times-quote .author,.post.mass .content .wp-block-pullquote cite,.post.mass .content .wp-block-quote cite,.post.mass .content p > a.button,.post.mass .content .wp-block-button .wp-block-button__link,.post.mass .content div.gallery .wp-caption-text,.post.mass .content .wp-block-file .wp-block-file__button,.post.mass .content .wp-block-latest-comments .wp-block-latest-comments__comment time,.post.mass .content .wp-block-latest-posts.is-grid li time,.post.mass .content form > p input[type='submit'], .post.mass .content form > p textarea[type='submit'],.post.mass .content .wp-block-times-button a,.post.mass .inaction,body.error404 .e404-header .go-back,body.error404 .e404-header .e404,body.error404 .widget-area.e404 .widget,body.error404 .times_get_archives li .count,body.error404 .most_used_categories .count,#comments .comment-meta,#comments .tvote-wrap,#comments .reply,#comments ul.children .comment-respond #cancel-comment-reply-link,#comments .times-comments-control .sorting div,#comments .times-comments-control .comments-pagination div,#comments .comment-list:before,#commentform .form-submit input,.widget-area.article-sidebar .tags .hash,.widget .widget-title,.widget_times_social_widget div,.bass-share-buttons,.post-author-bio h3,.post-author-bio .more-link,.times-mini-stats .stat,.stats .stat .text,.archive-pagination #scroll-top,.search-box .times-search-box .search-field,.search-box.animated .context,.query-fade-wrap .info,.search-form .search-submit,.stickyadelesq a,#wp-calendar caption,#wp-calendar thead, #wp-calendar tfoot,.site-footer .widget.categories a span.count,#times-ticker .ticker-content li .more-link,#times-ticker.font-type-sans-serif .ticker-content li,#times-legal-notice .notice-title{font-family:Domine,-apple-system,"Helvetica Neue","Segoe UI",Ubuntu,sans-serif;}</style><script type="text/javascript">function timesWO(o,n,e,t){var r=screen.width/2-e/2,i=screen.height/2-t/2;return window.open(o,n,"toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width="+e+", height="+t+", top="+i+", left="+r)}var timesStickySidebar=false;var timesSpecialLayout=true;var timesHeroParallax=false;var timesElevateClick=true;var timesLoadFade=true;var timesLoadFadeIn=false;var isSafariFade=/^((?!chrome|android).)*safari/i.test(navigator.userAgent);var timesScrollTo=true;var timesTransparentLabels=true;var timesAutoHyphenate="disabled";var timesHyphenateBranding=false;var timesExptTweak=false;var timesFeaturedParagraph=true;var timesAutoDropCap=true;var timesHeaderLayout='basic';var timesMenuLayout='basic';var timesMobileMenuLayout='mobile';var timesIsCustomizer=false;var timesIsTicker=false;var timesHomepagePostIDs=[];var timesIgnoreMailtoLinks=false;var timesHomepageUnique=true;var timesHomepageUsedPostsJSON=[];var timesSingularPostID=50028;var timesSingularBaseURL='/50028/news/south-slave/hay-river-keeps-holiday-spirit-alive-despite-covid-19/';var timesPostDisableFeaturedParagraph=false;var timesPostDisableAutoDropCap=false;var timesPostCommentPageNumber=1;var timesPostCommentDefaultSorting='oldest';</script></head>

<body class="post-template-default single single-post postid-50028 single-format-standard standard-article-layout">
<script type="text/javascript">(function($){"use strict";function fadeInPage(){function d(){setTimeout(function(){$("body").addClass("loaded")},8e3)}d(),1==isSafariFade&&$("body").addClass("zero loaded"),1==isSafariFade&&0==timesLoadFade&&$("body").ready(function(){$("body").addClass("zero loaded")}),1==timesLoadFadeIn&&$(window).bind("load",function(){$("body").addClass("loaded")}),$(window).bind("beforeunload",function(){1!=isSafariFade&&0!=timesLoadFade&&(timesIgnoreMailtoLinks?timesIgnoreMailtoLinks=!1:($("body").removeClass("zero loaded"),setTimeout(function(){$("body").addClass("loaded")},6e3))),d()})}$("html").addClass("js"),"opacity"in document.documentElement.style&&$("html").addClass("js-opacity"),"onmouseover"in document.documentElement&&$("html").addClass("hoverable"),fadeInPage();})(jQuery);if ( isSafariFade || timesLoadFade && !timesLoadFadeIn || !timesLoadFadeIn ) document.body.classList.add("zero", "loaded");</script><a class="skip-link screen-reader-text before-header-link" href="#content">Skip to content</a>

	<nav id="sec-navigation" class="layout-boxed background-dark padding-large">
		<div class="row">
			<div class="search-icon"><img src="https://cabinradio.ca/wp-content/themes/times/img/magni.svg" class="svg-inject"><span class="screen-reader-text">Search</span></div>
			
			<div class="menu-footer-container"><ul id="secondary-menu" class="menu"><li id="menu-item-14550" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-14550"><a href="https://cabinradio.ca/category/news/">Latest News</a></li>
<li id="menu-item-48054" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-48054"><a href="https://cabinradio.ca/48041/news/yellowknife/bullocks-co-op-cabin-radio-among-yk-business-award-winners/">YK&#8217;s Small Business of the Year 2020!</a></li>
<li id="menu-item-49662" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49662"><a href="https://cabinradio.ca/internships/">2021 Internships: Apply Now</a></li>
</ul></div>
						<div class="social-media-icons">
				<a class="facebook" href="https://facebook.com/cabinradio" target="_blank"></a> <a class="instagram" href="https://instagram.com/cabinradio" target="_blank"></a> <a class="twitter" href="https://twitter.com/cabinradio" target="_blank"></a> <a class="youtube" href="https://www.youtube.com/channel/UC5tlOgCA98-kP_K-keF4Ngg" target="_blank"></a> 			</div>
					</div>
	</nav>

<div class="row">
	<header id="masthead" class="site-header basic" role="banner">
		
		<div class="site-branding no-hy times-logo">
			<a href="https://cabinradio.ca/" rel="home"><img width="203" height="150" src="https://cabinradio.ca/wp-content/uploads/2020/10/Cabin-Radio-Orange-Logo-2-203x150.png"srcset="https://cabinradio.ca/wp-content/uploads/2020/10/Cabin-Radio-Orange-Logo-2-203x150.png 1x, https://cabinradio.ca/wp-content/uploads/2020/10/Cabin-Radio-Orange-Logo-2.png 2x" alt="Cabin Radio - Life&#039;s Better at the Cabin"></a>	</div>
		
			<nav id="site-navigation" class="main-navigation custom-menu" role="navigation">
	<ul id="primary-menu" class="clear"><li><a href="https://cabinradio.ca">Home</a></li><li><a href="https://cabinradio.square.site/">Store</a></li><li><a href="https://cabinradio.ca/live/">Listen Live</a></li><li><a href="https://cabinradio.ca/shows/">Schedule</a></li><li><a href="https://www.spreaker.com/user/cabinradio">Podcasts</a></li><li><a href="https://cabinradio.ca/partners/">Advertise</a></li><li><a href="https://cabinradio.ca/contact/">Contact</a></li><li><a href="https://cabinradio.ca/tips/">Tips</a></li></ul>	<div class="compact-menu row">
		<div class="wrap">
			<span class="compact-menu-btn"><img src="https://cabinradio.ca/wp-content/themes/times/img/hamburger.svg" class="svg-inject">Menu</span>
			<span class="title"><a href="https://cabinradio.ca/" rel="home"><img width="36" height="36" src="https://cabinradio.ca/wp-content/uploads/2020/10/Cabin-Radio-Orange-Circle-150px-36x36.png" srcset="https://cabinradio.ca/wp-content/uploads/2020/10/Cabin-Radio-Orange-Circle-150px-36x36.png 1x, https://cabinradio.ca/wp-content/uploads/2020/10/Cabin-Radio-Orange-Circle-150px-72x72.png 2x" alt="Cabin Radio - Life&#039;s Better at the Cabin"></a></span>
			<span class="compact-search-btn"><img src="https://cabinradio.ca/wp-content/themes/times/img/magni.svg" class="svg-inject"></span>
		</div>
	</div>
</nav>
<div class="search-cover"><div class="row"><form role="search" method="get" class="custom-search-form" action="https://cabinradio.ca/"><input type="submit" class="search-submit" value="Search"><input type="search" class="search-field" placeholder="What are you looking for?" value="" autocomplete="off" name="s" title="Search for:"><img src="https://cabinradio.ca/wp-content/themes/times/img/magni-big.svg" class="svg-inject search-icon"></form></div></div>				<div id="navshad"></div>
			</header>

	</div>
	<div class="row" id="content">

		<div class="col lt10">
			<article class="post mass single standard-layout post-50028 type-post status-publish format-standard has-post-thumbnail hentry category-south-slave" id="post-50028">

				<div class="introduction">
	<div class="category-labels"><div class="label full-text label-cat-id-1535"><span class="label-category-name">South Slave</span><a class="label-category-link" href="https://cabinradio.ca/category/news/south-slave/" rel="category"></a></div></div>	<h1 class="title">Hay River keeps holiday spirit alive despite Covid-19</h1>
	<p class="meta"><span class="published-ago"><time datetime="2020-11-27T08:21:43-07:00">Published: November 27, 2020 at 8:21am</time><span class="hyphen-single"></span></span><a href="https://cabinradio.ca/author/cabinsibley/" rel="author" class="author"> Sarah Sibley</a><span class="short-ago"><span class="hyphen-single"></span><time datetime="2020-11-27T08:21:43-07:00">November 27, 2020</time> </span></p></div>

				<hr>

				<figure class="featured-image"><img class="attachment-single-thumb size-single-thumb wp-post-image" alt="Yellowknife Christmas lights: Abominable snowmen on Kasteel Drive." width="4689" height="2638" srcset="https://cabinradio.ca/wp-content/uploads/2018/12/DSC02361.jpg 360w, https://cabinradio.ca/wp-content/uploads/2018/12/DSC02361.jpg 700w, https://cabinradio.ca/wp-content/uploads/2018/12/DSC02361.jpg 720w, https://cabinradio.ca/wp-content/uploads/2018/12/DSC02361.jpg 780w, https://cabinradio.ca/wp-content/uploads/2018/12/DSC02361.jpg 1120w, https://cabinradio.ca/wp-content/uploads/2018/12/DSC02361.jpg 1400w, https://cabinradio.ca/wp-content/uploads/2018/12/DSC02361.jpg 1560w, https://cabinradio.ca/wp-content/uploads/2018/12/DSC02361.jpg 2240w" sizes="(min-width:1200px) 780px, (min-width:1200px) and (min-aspect-ratio:2) 1560px, (min-width:600px) 700px, (min-width:600px) and (min-aspect-ratio:2) 1400px, (min-width:360px) 360px, (min-width:360px) and (min-aspect-ratio:2) 720px, 100vw"><figcaption>Christmas decorations at an NWT home. Sarah Pruys/Cabin Radio</figcaption></figure>
				<div class="content bass">
					<!-- Either there are no banners, they are disabled or none qualified for this location! -->
<p><strong>In the coming weeks, residents of Hay River looking for holiday cheer can check out everything from the classic Santa Claus parade to a new event at the town&#8217;s territorial park.</strong></p>



<p>Those hoping to check out this year’s floats and see Santa will have the chance on Friday, November 27 at 6:30pm. The Santa Claus parade, like Hay River&#8217;s Canada Day parade, will take a longer route through residential areas instead of sticking to the main street.</p>



<p>Floats will meet at 6pm in Bob McMeekin Park and <a href="https://www.facebook.com/1772690349505872/photos/a.2105093316265572/3472182079556682/">start their drive</a>. The route eventually crosses the highway and ends on the service road near Keith’s Water Services.</p><div class="gcabinr gcabinr-15"><div class="gcabinr-single acabinr-208"><p style="text-align:center"><font size="-2">Advertisement.</font><br><a class="gofollow" data-track="MjA4LDE1LDEsNjA=" href="https://www.qualityfurniturenwt.com/"><img src="https://cabinradio.ca/wp-content/uploads/2020/10/Quality-Furniture-AT.jpg" width="300px" /></a></p></div></div>



<figure class="wp-block-image alignnone size-large"><figure class="alignnone"><img data-attachment-id="50356" data-permalink="https://cabinradio.ca/50028/news/south-slave/hay-river-keeps-holiday-spirit-alive-despite-covid-19/attachment/hay-river-santa-parade/" data-orig-file="https://cabinradio.ca/wp-content/uploads/2020/11/hay-river-santa-parade.png" data-orig-size="1053,682" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="hay-river-santa-parade" data-image-description="" data-medium-file="https://cabinradio.ca/wp-content/uploads/2020/11/hay-river-santa-parade-300x194.png" data-large-file="https://cabinradio.ca/wp-content/uploads/2020/11/hay-river-santa-parade-960x622.png" loading="lazy" width="960" height="622" src="https://cabinradio.ca/wp-content/uploads/2020/11/hay-river-santa-parade-960x622.png" alt="" class="wp-image-50356" srcset="https://cabinradio.ca/wp-content/uploads/2020/11/hay-river-santa-parade-960x622.png 960w, https://cabinradio.ca/wp-content/uploads/2020/11/hay-river-santa-parade-300x194.png 300w, https://cabinradio.ca/wp-content/uploads/2020/11/hay-river-santa-parade-768x497.png 768w, https://cabinradio.ca/wp-content/uploads/2020/11/hay-river-santa-parade-780x505.png 780w, https://cabinradio.ca/wp-content/uploads/2020/11/hay-river-santa-parade-700x453.png 700w, https://cabinradio.ca/wp-content/uploads/2020/11/hay-river-santa-parade-360x233.png 360w, https://cabinradio.ca/wp-content/uploads/2020/11/hay-river-santa-parade-720x466.png 720w, https://cabinradio.ca/wp-content/uploads/2020/11/hay-river-santa-parade.png 1053w" sizes="(min-width:1200px) 740px, (min-width:1200px) and (min-aspect-ratio:2) 960px, (min-width:960px) 600px, (min-width:960px) and (min-aspect-ratio:2) 960px, (min-width:720px) 660px, (min-width:720px) and (min-aspect-ratio:2) 960px, (min-width:600px) 540px, (min-width:600px) and (min-aspect-ratio:2) 960px, (min-width:320px) 340px, (min-width:320px) and (min-aspect-ratio:2) 680px, (min-aspect-ratio:2) 200vw, 100vw" /><figcaption><span class="caption-text">A map of the route for the Hay River Santa Claus Parade. The green star is the start point, while the blue one is the end point.</span></figcaption></figure></figure>



<p>The lighting of the mayor’s tree will begin at 6:15pm, before the floats depart on their route.</p>



<p>The town recommends that families watch the parade from their home or vehicles in order to avoid gathering.</p>



<p>“Do not gather with people from outside of your household. If watching outside, please wear a mask if physical distancing cannot be maintained,” the <a href="https://www.facebook.com/Town-of-Hay-River-Recreation-110180367296510/photos/pcb.199143678400178/199143255066887">flyer for the event</a> states.</p>



<p>Nicole Mitchell, the organizer of the parade, plans to live-stream the parade on the <a href="https://www.facebook.com/Town-of-Hay-River-Recreation-110180367296510">Town of Hay River Recreation Facebook page.</a></p><div class="gcabinr gcabinr-16"><div class="gcabinr-single acabinr-298"><p style="text-align:center"><font size="-2">Advertisement.</font><br><a class="gofollow" data-track="Mjk4LDE2LDEsNjA=" href="https://www.mackenzierest.ca//"><img src="https://cabinradio.ca/wp-content/uploads/2019/07/Mackenzie-Rest-Inn-July-2019-1.jpg" width="300px" /></a></p></div></div>



<h3>Hay River campground Christmas</h3>



<p>Meanwhile, you can drive through a small winter wonderland at the Hay River Territorial Park.</p>



<p>For the first time, a loop of campsites will be adorned with holiday decorations and lights by businesses and residents.</p>



<p>The <a href="https://www.facebook.com/photo?fbid=10158349845486329&amp;set=gm.1283546865341514">event will take place</a> from December 4 to 6, with residents able to visit the campsite from 6pm to 10pm.</p>



<p>Admission is by grocery or cash donation.</p>



<p>Judy Pratt, one of the organizers, said it&#8217;s an event families can enjoy from a vehicle, making it easy to stay in a bubble.</p>



<p>“It just brings a little bit of festivity to the town in what might have been a season that didn’t have anything,” Pratt said.</p>



<p>At the end of the tour, visitors can hand in their votes for the best campsites. The top three campsites in two categories – business and resident – will win prizes.</p>



<p>Fort Smith is running a similar event called <a href="https://www.facebook.com/events/1243913265995447">Light Up the Park</a> in Queen Elizabeth Territorial Park. The event will run from December 13 until December 24, according to its Facebook page. Decorating of the campsites will take place from December 9 to 12.</p>



<h3>Annual Secret Santa</h3>



<p>Hay River’s <a href="https://www.facebook.com/hayriversecretsanta/">annual Secret Santa</a> has started with a new program coordinator, Tracy Cross Gauthier.</p>



<p>The event seeks toy donations for children aged up to 17. E-transfers are accepted, which will go toward groceries to supply people with Christmas dinners.</p>



<p>People visiting the bottle centre can <a href="https://www.facebook.com/hayriversecretsanta/photos/a.2149406275323933/2721365381461350/">donate their returns</a> by indicating they would like the balance applied to the Secret Santa account.</p>



<p>Donations are being collected until December 16.</p>



<p>Cross Gauthier says the tradition is even more important this year because people in the community have been struggling financially in the pandemic.</p>



<p>“Since Covid hit back in March, it’s had a devastating effect on families in Hay River. Even if you were able to keep your job, a lot of jobs had hours drastically reduced,” she said.</p>



<p>“It’s about the kids and getting them a little something under the tree. I just think it’s really important, especially this year.”</p>



<p>She adds many people are not able to be with their families and friends this season, so spreading the holiday spirit will be even more important.</p>



<p>She says in past years, 80 to 100 families participated in the program to receive gifts and Christmas dinners.</p>



<p>The major change to the program this year is people cannot get together in bigger groups to wrap presents, something community members typically enjoy.</p>



<p>Those looking to <a href="https://www.facebook.com/hayriversecretsanta/photos/a.2149406275323933/2726277914303430/">volunteer to wrap presents</a> can find information on the event&#8217;s Facebook page. </p>



<p>If you&#8217;re looking to donate gifts, a campsite at the Campground Christmas event will accept donations or there are boxes at various town locations.</p>



<h3>Toy Drive</h3>



<p>The 10th annual Toy Drive will happen in Hay River on December 5, starting at 11am.</p>



<p>Hay River Emergency Services will drive through the community to collect toys.</p>



<p>“Watch and listen for the lights and sirens as we will be driving through the community collecting donations of new, unwrapped gifts,” the event&#8217;s <a href="https://www.facebook.com/hayriversecretsanta/photos/a.2149406275323933/2721342641463624/">flyer reads.</a></p>
<div class="gcabinr gcabinr-20"><div class="gcabinr-single acabinr-317"><p style="text-align:center"><font size="-2">Advertisement.</font><br><a class="gofollow" data-track="MzE3LDIwLDEsNjA=" href="https://namushkalodge.com/"><img src="https://cabinradio.ca/wp-content/uploads/2020/10/20201002-Namushka.jpg" width="300px" /></a></p></div></div></p>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>									</div>

				<aside class="mobile-post-info mobile-sidebar">
					<section class="post-author-bio"><h3>Sarah Sibley</h3><p>Local Journalism Initiative reporter, Dehcho and housing. <a href="mailto:sarah.sibley@cabinradio.ca">Contact Sarah</a> <a href="https://cabinradio.ca/author/cabinsibley/" class="more-link">More <span>&raquo;</span></a></p></section>
					
									</aside>

				<section class="inaction clear"></section>
			</article>
		</div>

		<div class="col lt5">

			<div class="stats">
				
				
			</div>

			<aside class="widget-area article-sidebar">

								<section class="widget post-info">
					<h2 class="widget-title bd2">Article info</h2>

					<section class="post-author-bio"><h3>Sarah Sibley</h3><p>Local Journalism Initiative reporter, Dehcho and housing. <a href="mailto:sarah.sibley@cabinradio.ca">Contact Sarah</a> <a href="https://cabinradio.ca/author/cabinsibley/" class="more-link">More <span>&raquo;</span></a></p></section>
									</section>
				
				
				
				<div class="user-widgets user-widgets-article">
					              <section id="patreon_sidebar_user_widget-4" class="widget bass widget_patreon_sidebar_user_widget">                  							
																	<div style="text-align: center !important;font-size: 18px;margin-top: 10px;margin-bottom: 10px;">Drive independent NWT journalism by Sarah Sibley and Cabin Radio, from just $1/month</div>
								
	<div class="cb_p6_patreon_author_widget" style="text-align:center !important;"><a rel="nofollow" href="https://www.patreon.com/cabinradio?utm_content=author_sidebar_widget&utm_medium=patron_button_and_widgets_plugin&utm_campaign=&utm_term=&utm_source=https://cabinradio.ca/50028/news/south-slave/hay-river-keeps-holiday-spirit-alive-despite-covid-19/"><img style="margin-top: 10px;margin-bottom: 10px;max-width:200px;width:100%;height:auto;" src="https://cabinradio.ca/wp-content/plugins/patron-button-and-widgets-by-codebard/images/become_a_patron_button.png"></a></div>							
     
						
              </section>        <section id="5f78fbd588637-2" class="widget bass 5f78fbd588637"><div class="gcabinr gcabinr-7"><div class="gcabinr-col bcabinr-7 acabinr-218"><center><a class="gofollow" data-track="MjE4LDcsMSw2MA==" href="https://gmob.ca/"><img src="https://cabinradio.ca/wp-content/uploads/2020/04/GMOB_Cabin-Radio-Ad-3.jpg" width="300px" /></a></center></div><div class="gcabinr-col bcabinr-7 acabinr-317"><center><a class="gofollow" data-track="MzE3LDcsMSw2MA==" href="https://namushkalodge.com/"><img src="https://cabinradio.ca/wp-content/uploads/2020/10/20201002-Namushka.jpg" width="300px" /></a></center></div><div class="gcabinr-col bcabinr-7 acabinr-285"><center><a class="gofollow" data-track="Mjg1LDcsMSw2MA==" href="https://yellowknifecentre.ca/"><img src="https://cabinradio.ca/wp-content/uploads/2020/11/2020-11-25-FINAL-BANNER-AD-JULIE-GREEN-SHARE-YOUR-IDEAS-_-CABIN-AD-1.png" width="300px" /></a></center></div><div class="gcabinr-col bcabinr-7 acabinr-208"><center><a class="gofollow" data-track="MjA4LDcsMSw2MA==" href="https://www.qualityfurniturenwt.com/"><img src="https://cabinradio.ca/wp-content/uploads/2020/10/Quality-Furniture-AT.jpg" width="300px" /></a></center></div></div></section><section id="srpw_widget-6" class="widget bass widget_smart_recent_entries smart_recent_posts"><h2 class="widget-title bd2">The Latest</h2><div class="srpw-block srpw-classic-style "><ul class="srpw-ul"><li class="srpw-li srpw-clearfix"><div class="srpw-content"><a class="srpw-title" href="https://cabinradio.ca/50342/news/yellowknife/yk-immigration-consultant-must-pay-185k-to-former-client/" target="_self">YK immigration consultant must pay $185K to former client</a><div class="srpw-meta"><time class="srpw-time published" datetime="2020-11-27T09:34:50-07:00">November 27th, 2020</time></div></div></li><li class="srpw-li srpw-clearfix"><div class="srpw-content"><a class="srpw-title" href="https://cabinradio.ca/50364/video/kids-produce-video-celebrating-fort-resolution/" target="_self">Kids produce video celebrating Fort Resolution</a><div class="srpw-meta"><time class="srpw-time published" datetime="2020-11-27T07:55:06-07:00">November 27th, 2020</time></div></div></li><li class="srpw-li srpw-clearfix"><div class="srpw-content"><a class="srpw-title" href="https://cabinradio.ca/50320/news/arts/fort-smith-student-curates-museum-exhibit/" target="_self">Fort Smith student curates museum exhibit</a><div class="srpw-meta"><time class="srpw-time published" datetime="2020-11-26T15:28:03-07:00">November 26th, 2020</time></div></div></li><li class="srpw-li srpw-clearfix"><div class="srpw-content"><a class="srpw-title" href="https://cabinradio.ca/50309/news/beaufort-delta/rcmp-seize-32-bottles-of-vodka-destined-for-fort-mcpherson/" target="_self">RCMP seize 32 bottles of vodka destined for Fort McPherson</a><div class="srpw-meta"><time class="srpw-time published" datetime="2020-11-26T12:18:28-07:00">November 26th, 2020</time></div></div></li><li class="srpw-li srpw-clearfix"><div class="srpw-content"><a class="srpw-title" href="https://cabinradio.ca/50286/news/yellowknife/holiday-parties-off-the-menu-in-many-yellowknife-establishments/" target="_self">Holiday parties off the menu in many Yellowknife establishments</a><div class="srpw-meta"><time class="srpw-time published" datetime="2020-11-26T07:25:09-07:00">November 26th, 2020</time></div></div></li></ul></div><!-- Generated by http://wordpress.org/plugins/smart-recent-posts-widget/ --></section>				</div>

			</aside>
		</div>
	</div>

	<div class="section-darker">
	<div class="row">

		<div class="col st8 lt10">
					</div>

		<aside class="col st7 lt5 widget-area singular-comments-sidebar article-comments-sidebar">

			
			
			
			
		</aside>

	</div>
	</div>

<footer class="site-footer basic-layout customizer-logo custom-layout column-count-2">
	<div class="row">

	
	<div class="widget-area col"><section id="text-30" class="widget bass widget_text"><h2 class="widget-title">Contact us</h2>			<div class="textwidget"><p><strong>Email:</strong> <a href="mailto:mailbox@cabinradio.ca">mailbox@cabinradio.ca</a></p>
<p><strong>Phone: </strong>(867) 765-5079</p>
<p><strong>Mail:</strong> Cabin Radio<br />
PO Box 2545, 5007 50 Avenue<br />
Yellowknife, NT X1A 2P8</p>
</div>
		</section></div><div class="widget-area col"><section id="text-3" class="widget bass widget_text"><h2 class="widget-title">Our Journalism</h2>			<div class="textwidget"><p>Read Cabin Radio&#8217;s <a href="https://cabinradio.ca/7849/on-air/our-commitment-to-ethical-journalism/">journalism ethics</a> and our register of interests. <a href="https://cabinradio.ca/concerns/">Have a concern</a>? Let us know.</p>
</div>
		</section><section id="text-28" class="widget bass widget_text"><h2 class="widget-title">Local Journalism Initiative reporting</h2>			<div class="textwidget"><p>Funded by the Government of Canada. Financé par le gouvernement du Canada.</p>
<p><img loading="lazy" class="wp-image-33026 aligncenter" src="https://cabinradio.ca/wp-content/uploads/2020/03/wordmark_C.png.png" alt="" width="122" height="29" srcset="https://cabinradio.ca/wp-content/uploads/2020/03/wordmark_C.png.png 470w, https://cabinradio.ca/wp-content/uploads/2020/03/wordmark_C.png-300x71.png 300w, https://cabinradio.ca/wp-content/uploads/2020/03/wordmark_C.png-360x86.png 360w" sizes="(min-width:1200px) 122px, (min-width:1200px) and (min-aspect-ratio:2) 122px, (min-width:960px) 122px, (min-width:960px) and (min-aspect-ratio:2) 122px, (min-width:720px) 122px, (min-width:720px) and (min-aspect-ratio:2) 122px, (min-width:600px) 122px, (min-width:600px) and (min-aspect-ratio:2) 122px, (min-width:320px) 122px, (min-width:320px) and (min-aspect-ratio:2) 122px, (min-aspect-ratio:2) 200vw, 100vw" /></p>
</div>
		</section></div>
	</div>
	<div class="row">
		<div class="site-branding">
			<div class="col st5"><span class="aligner"></span><a href="https://cabinradio.ca/" rel="home"><img width="240" height="48" src="https://cabinradio.ca/wp-content/uploads/2020/10/Cabin-Radio-Orange-Circle-240px.png" alt="Cabin Radio - Life&#039;s Better at the Cabin"></a></div>
			<div class="col st10"><p class="footer-text-selective">© 2020 506992 NWT Ltd, operating as <a class="sitettl" href="https://cabinradio.ca">Cabin Radio</a>. The second-biggest variety in the North.</p></div>
		</div>
	</div>
</footer><!--  -->
<script defer id='bilmur' data-provider='wordpress.com' data-service='atomic' src='https://s0.wp.com/wp-content/js/bilmur.min.js?m=202048'></script>
<div id="aioseo-admin"></div><link rel='stylesheet' id='all-css-83b8a4c593d640f36f9fea2f0abc651a' href='https://cabinradio.ca/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.css?m=1593527050' type='text/css' media='all' />
<script id='adrotate-clicktracker-js-extra'>
var click_object = {"ajax_url":"https:\/\/cabinradio.ca\/wp-admin\/admin-ajax.php"};
</script>
<script type='text/javascript'  src='https://cabinradio.ca/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js?m=1606322475'></script>
<script src='https://cabinradio.ca/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script id='imagesloaded-js-after'>
(function ($) { "use strict"; $('#masthead .site-branding').imagesLoaded( function() { if ( $('#masthead .adele-wrap').length || $('#masthead .site-branding img').length ) {if (typeof scrollToContent !== 'undefined') scrollToContent();} }); })(jQuery);
</script>
<script id='contact-form-7-js-extra'>
var wpcf7 = {"apiSettings":{"root":"https:\/\/cabinradio.ca\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
</script>
<script type='text/javascript'  src='https://cabinradio.ca/_static/??-eJyVkE1ywjAMhS9Ux9BFWDE9iyMrQcGWjCUDvX2BZrrI0BmY0UrvfU8/l+JA2JDNl9QmYvUwcI3iRgzWKkZ3pojigyqa+vlPL21IBC5UI0jo1ALHUGM368flSagMSeCoPpLaI2VpuMCUg5Hw22Si6WCDXP8F2QKYG6Vmt/PEkFrExwkKlYrpCrQD5ptulBfXeXLEM4JJ7TKtF1zb51PD+t1Fsd96ASkE9x+PlNIrA7QDkSPh4v3K+22/6be7zWff/wDRLKy9'></script>
<script id='times-scripts-js-before'>
var ajaxUrl="https://cabinradio.ca/wp-admin/admin-ajax.php";var rootUrl="https://cabinradio.ca/wp-content/themes/times";var siteLang="en";
</script>
<script src='https://cabinradio.ca/wp-content/themes/times/js/times-scripts.min.js?ver=1.5.2' id='times-scripts-js'></script>
<script id='times-vote-js-js-extra'>
var timesVotes = {"ajaxurl":"https:\/\/cabinradio.ca\/wp-admin\/admin-ajax.php","like":"Like","unlike":"Unlike"};
</script>
<script id='wp-postviews-cache-js-extra'>
var viewsCacheL10n = {"admin_ajax_url":"https:\/\/cabinradio.ca\/wp-admin\/admin-ajax.php","post_id":"50028","transient":"false"};
</script>
<script id='jetpack-carousel-js-extra'>
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/cabinradio.ca\/wp-admin\/admin-ajax.php","nonce":"45271161e4","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/cabinradio.ca\/wp-login.php?redirect_to=https%3A%2F%2Fcabinradio.ca%2F50028%2Fnews%2Fsouth-slave%2Fhay-river-keeps-holiday-spirit-alive-despite-covid-19%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
</script>
<script type='text/javascript'  src='https://cabinradio.ca/_static/??-eJyVkdFOwzAMRX+INJs0QDwgPgWlqbe6TZwQ2yvw9aRDY3sAlL1EsXOPj6ws2fhEAiRWRojAVnA9J7YxDVAIP0vXK4ahi0jdxHfL38TpYiKQNoSVUsmjqwLopjeF8tFsYKSDBlcM+4JZuAH0AXOfXGlfY5UEMCyOhsrd4OIZswlIs9knr2z2+N5sPSaBhnBOLEeEhY13frwmkHzQ4TtVS4g9/LZzDnpAqimQ7PxsXytnT/9svStJGcL5zZwb/4ypraDkihswreaf4gYGCeXCTfwSn7cPm93ucbu5f/oC/asBWA=='></script>
<script type='text/javascript' src='https://stats.wp.com/e-202048.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.1',blog:'135450906',post:'50028',tz:'-7',srv:'cabinradio.ca'} ]);
	_stq.push([ 'clickTrackerInit', '135450906', '50028' ]);
</script>

</body>
</html>
